[PATCH] test: check for GNU parallel with --version options

classic Classic list List threaded Threaded
2 messages Options
Tobias Backer Dirks Tobias Backer Dirks
Reply | Threaded
Open this post in threaded view
|

[PATCH] test: check for GNU parallel with --version options

The lastest versions of GNU parallel no longer make mention of GNU
within their help output. This causes the test script to mistakenly use
the moreutils parallel execution. In order to fix this, while
maintaining compatibility with previous versions of GNU parallel,
--version should be used.

Signed-off-by: Tobias Backer Dirks <[hidden email]>
---
 test/notmuch-test | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

diff --git a/test/notmuch-test b/test/notmuch-test
index b58fd3b3..91909264 100755
--- a/test/notmuch-test
+++ b/test/notmuch-test
@@ -50,7 +50,7 @@ META_FAILURE=
 # Run the tests
 if test -z "$NOTMUCH_TEST_SERIALIZE" && command -v parallel >/dev/null ; then
     test -t 1 && export COLORS_WITHOUT_TTY=t || :
-    if parallel -h | grep -q GNU ; then
+    if parallel --version | grep -q GNU ; then
         echo "INFO: running tests with GNU parallel"
         printf '%s\n' $TESTS | $TEST_TIMEOUT_CMD parallel
     else
--
2.31.1
_______________________________________________
notmuch mailing list -- [hidden email]
To unsubscribe send an email to [hidden email]
David Bremner-2 David Bremner-2
Reply | Threaded
Open this post in threaded view
|

Re: [PATCH] test: check for GNU parallel with --version options

Tobias Backer Dirks <[hidden email]> writes:

> The lastest versions of GNU parallel no longer make mention of GNU
> within their help output. This causes the test script to mistakenly use
> the moreutils parallel execution. In order to fix this, while
> maintaining compatibility with previous versions of GNU parallel,
> --version should be used.

Applied, thanks!

d
_______________________________________________
notmuch mailing list -- [hidden email]
To unsubscribe send an email to [hidden email]