[PATCH] mime-node: be clearer about decryption

classic Classic list List threaded Threaded
2 messages Options
Daniel Kahn Gillmor Daniel Kahn Gillmor
Reply | Threaded
Open this post in threaded view
|

[PATCH] mime-node: be clearer about decryption

Part 0 of a multipart/encrypted object is
GMIME_MULTIPART_ENCRYPTED_VERSION; part 1 is
GMIME_MULTIPART_ENCRYPTED_CONTENT.  Using the name for what we want
describes our intent more clearly than using a magic number in the
code.

Signed-off-by: Daniel Kahn Gillmor <[hidden email]>
---
 mime-node.c | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

diff --git a/mime-node.c b/mime-node.c
index 3492bcd0..a93cbb31 100644
--- a/mime-node.c
+++ b/mime-node.c
@@ -339,7 +339,7 @@ mime_node_child (mime_node_t *parent, int child)
  return NULL;
 
     if (GMIME_IS_MULTIPART (parent->part)) {
- if (child == 1 && parent->decrypted_child)
+ if (child == GMIME_MULTIPART_ENCRYPTED_CONTENT && parent->decrypted_child)
     sub = parent->decrypted_child;
  else
     sub = g_mime_multipart_get_part
--
2.20.1

_______________________________________________
notmuch mailing list
[hidden email]
https://notmuchmail.org/mailman/listinfo/notmuch
David Bremner-2 David Bremner-2
Reply | Threaded
Open this post in threaded view
|

Re: [PATCH] mime-node: be clearer about decryption

Daniel Kahn Gillmor <[hidden email]> writes:

> Part 0 of a multipart/encrypted object is
> GMIME_MULTIPART_ENCRYPTED_VERSION; part 1 is
> GMIME_MULTIPART_ENCRYPTED_CONTENT.  Using the name for what we want
> describes our intent more clearly than using a magic number in the
> code.
>

pushed to master

d
_______________________________________________
notmuch mailing list
[hidden email]
https://notmuchmail.org/mailman/listinfo/notmuch